checklist_check_before_1st_flight

This is an old revision of the document!


In General you will find a list of things that are required regardless of your Operating System or flight simulator platforms used. The rest of this chapter deals with items that are specific to OS and flight simulator platforms.


☑   Are there any CSL or AI aircraft models installed? Download Models
☑   Have you created a Model Set with the help of the Configuration Wizard? First Model Set
☑   If you don't mind, enable crashdump reports to help developers analyze the cause of crashes
☑   Close other pilot clients, so the voice port is not blocked. X-Plane users need to make sure that plugins of other online flying clients are completely disabled
☑   Do not touch the gnd.flag and fast position settings unless you know what you are doing!
☑   Do not run swiftCore and swiftGUI in standalone mode on the same computer. Normally swiftCore is only needed by users who want to run swift in Distributed Mode (on a remote computer)
☑   Do you get model validation errors on program startup? If there are a lot of validation error messages, something in your setup may be wrong: Help Page
☑   Make sure malware protection allows swift to run. “Acronis TrueImage Active protection” and similar programs may be interfering



macOS

☑   Enable the microphone for swift: Help Page
 


Windows

☑   make sure swift can access your microphone: Help Page
 


Linux

☑   Hotkeys: We read keyboard and joystick stuff from /dev/input/event and js. Those files have to be readable by your user. Typically they are owned by group input or such, so if you add your user to that group, then it will work: Help Page
 


X-Plane 11

swift is compatible with OpenGL and Vulkan/Metal. X-Plane has seen significant internal changes, as a consequence you have to use specific verisons of swift to correctly display aircraft and to have an operational TCAS! Until including X-Plane 11.41 you have to use swift version 0.9.4.389. From X-Plane 11.50 download and install swift 0.9.5.x or newer.

☑   use the 64bit version of swift
☑   make sure XSwiftBus is installed and that its version number is identical with the one of swiftGUI
☑   traffic plugins and other pilot clients for X-Plane will interfere with XSwiftBus and need to be properly deactivated or removed from the plugins folder. More info
☑   CSL models must be installed inside the folder of X-Plane, it is advisable to avoid spaces and special characters in the file paths. More information and recommendations
☑   if your BlueBell Models are being displayed inside the ground or floating above it, download and install the latest version of them, it already contains a fix for this: More information


FSX & P3D

  

☑   use swift 32bit for FSX and P3D v1-v3, swift 64bit for P3D v4 and newer
☑   P3D: to use external model directories (not in SimObjects) add this directory in your simulator settings
☑   FSX & P3D v1-v3: make sure that the terrain probe is installed: Help Page
☑   enable Simconnect Offsets in the driver settings if you want to use ATC Transponder updates from PMDG and other aircraft
☑   you cannot connect swift to P3D or FSX? If you run P3D/FSX as Admin, then run swift as Admin as well


FS9

☑   make sure FSUIPC is installed, swift needs FSUIPC to work properly
☑   if you run FS9/FSUIPC as Admin, run swift as Admin as well
☑   since Windows 10 Update 1909, the automatic connect function between swift and FS9 may not work anymore. You will have to connect FS9 manually
☑   consider the Ground Elevation recording: Help Page

  • checklist_check_before_1st_flight.1600288722.txt.gz
  • Last modified: 2020/09/16 22:38
  • by flyingfox